Search CTAT

CTAT Requirements

System Requirements

  • Windows 7 and above or Mac OS X 10.7.3 (Lion) and above.
  • The CTAT installer and Authoring Tools require the J2SE Java Runtime Environment (JRE) version 1.7 or greater. Not sure if you have Java? Click here to check.

Software Requirements

  • HTML interface building requires an editor. If you use the CTAT HTML Editor, the Google Drive app or the Dropbox Basic app is required for syncing a cloud folder to a local one. Otherwise, a simple text editor or one that supports HTML (such as Sublime) is required.
  • Cognitive tutors require a program for editing production rules. CTAT provides a Jess editor plug-in for the Eclipse IDE. Eclipse is recommended, though not required. If you do not already have Eclipse installed, we recommend using the Kepler (4.3) release of the Eclipse IDE (Select Eclipse IDE for Java Developers.)

Software requirements for Flash and Java interfaces:

Note: We recommend developing student interfaces in HTML. Flash and Java interfaces are still supported but are no longer being actively developed.

Continue to Download CTAT.