Download CTAT


System Requirements

CTAT requires the following software:

  • Windows 7 and above or Mac OS X 10.7.3 (Lion) and above.
  • The CTAT installer and Authoring Tools require the J2SE Java Runtime Environment (JRE) version 1.7 or later. Not sure if you have Java? Click here to check.

Get Software for Developing Tutors

Choose either HTML, Flash, or Java for developing student interfaces. See our guide to choosing as well as our matrix of tutor features.

Note: We recommend developing student interfaces in HTML. Flash and Java interfaces are still supported but are no longer being actively developed.

HTML Tutors

The CTAT HTML editor can be used to create student interfaces. If you prefer to edit your HTML by hand, an HTML editor, such as Sublime, is recommended.

or

Flash Tutors

Flash CS6 or greater is required to develop new student interfaces with Flash. Flash CC (now Animate) is recommended.

or

Java Tutors

Eclipse with WindowBuilder and the JDK (Java Development Kit) version 7 or greater are required to create new student interfaces in Java.

Cognitive Tutors (HTML, Java, or Flash)

Cognitive tutors require a program for editing production rules. Eclipse IDE is recommended, though not required.

Looking for an older release?

Contact us